Monday, January 5, 2015

How To Solve A Failure [INSTALL_FAILED_OLDER_SDK] When Using Android Studio

There are some times when even though you KNOW what to do, you forget some small detail that causes you to waste time. When building Android projects, you know to add the minimum supported version to your manifest file. Well when using Android Studio to create Android projects, Gradle ignores your manifest file. This can make for a little bit of head-scratching as you are trying to figure out why your newly created project isn't running as you expected.

If you get the following error:

Failure [INSTALL_FAILED_OLDER_SDK]

Look build.gradle file for your app and change the following :

defaultConfig {
        applicationId "com.example.test.myapplication1"
        minSdkVersion 15
        targetSdkVersion 21
        versionCode 1
        versionName "1.0"
    }

Notice the highlight. You are going to change minSdkVersion to a version that matches your target test device. Issue solved!

Smooches!
Kila

4 comments:

fanny said...

There are two things to aim at in life: first, to get what you want; and ,after that, to enjoy it , only the wisest of mankind achieve the second.
_________________________
I find a interest game, join us now!: http://www.Fastfifa16.co.uk/
Cheap FIFA 16 Coins

Anonymous said...

I had a problem with A Brother HL-2250DN - toner light stuck on after new cartridge. I followed your reset instructions for the 2240 model and hey!!! it worked - thanks soooo much for your useful blog :)))))

kongponleu88 said...


Thank you for sharing valuable information. Nice post. I enjoyed reading this post.
โกเด้นสล็อต

raybanoutlet001 said...

nike huarache
jordan 4
ugg boots
ugg boots
ralph lauren outlet
nike outlet
coach outlet
louboutin shoes
michael kors outlet
michael kors outlet online